Error en WP 3.5: wpdb::prepare()

Resulta que la actualización de WordPress 3.5 tiene un error que a muchos de nosotros nos vino a dar lata en nuestros sitios, dicho error tiene que ver con la  funcion wpdb::prepare() y marca un error en la linea 990 del archivo wp-db.php de la carpeta wp-includes, esto realmente no se a que se debe, algunos comentarios dicen que es un error de la base de datos, otros que es un choque entre plugins… mientras son peras o manzanas, en los foros de soporte de WordPress.org (en inglés) hay una solución:

1. Conectarse por FTP al servidor y descargar el archivo correspondiente (wp-db.php) que se encuentra en la carpeta wp-includes

2. Editar la linea 990 del archivo wp-db.php que debe decir algo asi–>  function prepare( $query, $args) {

y sustituirla por lo siguiente:

function prepare( $query, $args = "" ) {

3. Guardar el archivo editado, subirlo al servidor y sobreescribir el existente.

4. Voilá! ya no tenemos error.

 

Fuente: Foro de soporte WP

Milenial amante de la fotografía, los viajes y del amor · LCC · Colaboro donando fotografías en Pixabay y Unsplash.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

subir